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Introduction

This example illustrates modeling using the Electric Currents application mode of 
the COMSOL Multiphysics Electomagnetics Module and its applications for 
dielectrophoresis (DEP), impedance sensors within BioMEMS, as well as general 
capacitance-resistance computations where inductive effects can be neglected. The 
model was inspired by the COMSOL based papers of Ref. 1 and Ref. 2 below. 

Model Definition

The modeling domain consists of a cube of side 30 µm. The cube is filled with a 
buffer (see Ref. 1) with σ=0.56 S/m and εr=78. The five upper boundaries of the 
cube represents an artificial truncation of the buffer volume. The lower boundary 
of the cube is partitioned into five segments representing four gold electrodes and 
a non-conducting boundary. Two of the electrodes are grounded and the other two 
have a peak potential of 10 V at 1 MHz. The electrodes are modeled as perfect 
conductors and are considered to be equipotential surfaces with no finite thickness. 
The advantage of modeling the electrodes as infinitely thin is that much fewer 
elements are needed to accurately capture the most important aspects. Fewer 
elements means lower memory requirements and faster computation times.
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The modeled domain. The red electrodes are set to 10 V (AC) and the blue electrodes are set to ground (0 
V).

This example uses the Electric Currents application mode and the unknown field 
quantity is the voltage V=V(x,y,z), a complex-valued quantity. The Electric Currents 
application mode is used to model devices with alternating currents (AC) where 
magnetic-inductive effects can be neglected and only resistive-conductive and 
electric-capacitive effects are accounted for. Generally speaking, this approximation 
gets better the lower the frequency and the smaller the device. When this 
approximation cannot be applied, you instead need to use the Electric and 
Induction Currents application mode.

For more information on the various approximations used, see the below section on 
Model Approximations.
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The geometry is meshed using the automatic tet-mesher and the default 
“nodal-based” second order elements are used.

The finite element mesh. Second order tetrahedral elements are used for discretizing the complex valued 
electric potential V.

Please note that this simulation can be made with just 1/4 of the geometry due to 
symmetry.

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 In the Model Navigator, select 3D in the Space Dimension list and then 
Electromagnetics Module>Quasi-statics, Electric>Electric Currents>Time-harmonic 

analysis in the list of application modes.

3 Click OK.

G E O M E T R Y  M O D E L I N G

Firstly, create the box containing the buffer (a truncated portion of the real-world 
volume).

1 From the Draw menu, select Work Plane Settings.
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2 Click OK to create a default work plane located at z=0.

3 Shift-Click the second Rectangle/Square button. A Square dialog box opens.

4 Type 30e-6 in the Width text field.

5 Change the Base to Center.

6 Click OK to create the square.

7 Click the Zoom Extents button to adjust the axis settings down to the micron 
scale.

8 From the Draw menu, select Extrude.

9 For Distance, type 30e-6. The dimensions are SI by default - so the distance 
entered is 30 micrometers. If needed, this can be changed form the Physics 
menu>Model Settings.

10 Click OK.

Secondly, create the four electrodes.

1 Click the Geom2 tab to get back into the work plane.

2 Create a rectangle covering the upper left quarter of the already drawn square.

3 Double-click the rectangle, a Rectangle dialog box opens.
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4 Adjust the settings to Width: 1.15E-5, Height: 1.15E-5, Base: Corner, x: -1.5E-5, 
y: 3.5E-6.

5 Continue in the same way to create rectangles covering the other three corners 
of the square.

6 Click the Chamfer/Fillet toolbar button to open the corresponding dialog box.

7 Click the inner corners of the four smaller squares (use Ctrl-Click for multiple 
selection).

8 Use a fillet-radius of 0.15e-5.
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9 Click OK to create the fillets.

10 From the Draw menu, select Embed.

11 Select all four filleted-squares (do not select the larger square!).
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12 Click OK to embed the objects in 3D.

P H Y S I C S  S E T T I N G S

Subdomain Settings
The following steps will set the material properties for the buffer.

1 From the Physics menu, open Subdomain Settings.

2 For the Electric conductivity, type 0.56.

3 For the Relative permittivity, type 78.

4 Click OK.

Boundary Conditions
1 From the Physics menu, open Boundary Settings.

2 Press Ctrl+A to select all boundaries and change the Boundary condition to Electric 

insulation.

3 Select boundaries 3 and 9 (two of the gold electrodes) and change the Boundary 

condition to Ground.

4 Select boundaries 6 and 8 (the other two of the gold electrodes) and change the 
Boundary condition to Electric potential and type 10 for the Electric potential. This 
will define a time-varying potential V(t)=10cos(2πft) for these two electrodes.
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5 Click OK.

Scalar Variables (Setting the Frequency)
For the first part of the simulation, the frequency will be fixed.

1 From the Physics menu, select Scalar Variables.

2 Change the Frequency to 1MHz by typing 1e6 in the corresponding text field.

3 Click OK.

M E S H  G E N E R A T I O N

For this model, the default mesh will do.

1 Click the Initialize Mesh button.

C O M P U T I N G  T H E  S O L U T I O N

For this model, the default solver settings will do.

1 Click the Solve button.

V I S U A L I Z A T I O N

The default plot shows a slice plot of the electric potential:

1 From the Postprocessing menu, open the Plot Parameters dialog box.
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2 On the Slice page, change the Number of levels to be 1 in the x-direction, 1 in the 
y-direction, and Vector of coordinates set to 1e-6 for the z-direction:
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DEP Force Field Visualization

This section covers DEP force field visualization. If you are interested in frequency 
dependent impedance (resistance+capacitance) computations, please skip to the 
next section Impedance Computation.

A quantity that is of interest for dielectrophoresis (DEP) simulations is the 
magnitude of the square of the gradient of the electric field:

FDEP k E E∗⋅( )∇ E E∗⋅( )∇⋅=

where the * denotes complex-conjugation and k is a coefficient that depends on the 
shape of the particle. This so called DEP-force acts on a small dielectric particle in a 
nonuniform field. For more information see Ref. 1 and Ref. 3, page 10-8.

The force vector on the particle is:

FDEP k E E∗⋅( )∇=
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The DEP force expression is not a built-in expression for the Electric Currents 
application mode, but can be formed as a composite expression of the already 
defined components of the electric field: Ex_emqvw, Ey_emqvw, and Ez_emqvw (or 
equivalently the already defined components of the gradient of the electric potential 
Vx, Vy, and Vz).

The expression is a bit lengthy, but a minimum of computations is needed if the 
built-in diff() operator is used. As an example of the use of the diff-operator, 
consider the expression diff(V,x) that means the partial derivative of the electric 
field V with respect to x (also available as the built-in Vx).

To make it easier, we can first use the fact that the quantity:

E E∗⋅ E=

is already a named variable normE_emqvw - the magnitude, or norm, of the electric 
field. We can then get the square of the electric field as normE_emqvw^2.

The gradient components can then be computed as: diff(normE_emqvw^2,x), 
diff(normE_emqvw^2,y), and diff(normE_emqvw^2,z).

Finally, the DEP force can be computed as the expression:

k*sqrt(diff(normE_emqvw^2,x)^2+diff(normE_emqvw^2,y)^2+        
  diff(normE_emqvw^2,z)^2)

Now, let’s create a user-defined expression for this force:

1 From the Options menu, select Expressions>Scalar Expressions.

2 Create an Expression variable with the name k and expression equal to 1 (we do 
not pay attention to the particle shape at this stage).

3 Create an Expression variable with the name FDEP and expression as above.

4 Click OK.

To visualize the force-field, we first need to evaluate the expression:

1 From the Solve menu, select Update Model.

This will evaluate the expression for FDEP throughout the mesh and make it available 
for visualization and postprocessing.

To visualize:

1 From the Postprocessing menu, open the Plot Parameters dialog box.

2 On the Slice page, change the Expression to FDEP.
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3 Click OK.

The accuracy of the FDEP computation is quite poor due to the fact that:

1 A very coarse mesh is used that doesn’t resolve the fields close to the electrode 
edges well

2 Second order elements are used. This means that the solution is approximated 
within each element using second-order polynomials. The DEP force is 
computed as an expression in the electric field gradients and the electric field, in 
turn, is computed as the gradient to the electric field. This means that the DEP 
force is a quantity that is composed of the field variable V differentiated twice. As 
such, it is represented by a constant value within each element (the second order 
polynomials differentiated twice).

Remedy for this is to use a finer mesh and/or to increase the element order (from 
the Subdomain Settings, Element page). By increasing the element order to cubic 
elements, the DEP force will be approximated by linear functions within each 
element.

Let’s try refining the mesh and not increasing the element order (to avoid a very 
memory consuming computation).

1 From the Mesh menu, select Mesh parameters.
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2 On the Edge page, select edges 7,9,13,14,15,17,19, 21,22,23,25, and 26. 
These are the edges of the electrodes.

3 Change the Maximum edge size to 0.1e-6.

4 Click Remesh.

Click the Solve button to compute the solution for the new mesh.

The force is quickly attenuated as we move away from the electrode edges. To better 
visualize the force variations we can use a logarithmic plot (with base 10).

1 From the Postprocessing menu, open the Plot Parameters dialog box.

2 On the Slice page, change the Expression to log10(FDEP).

3 To get a slice closer to the electrode, change the Vector of coordinates to 1e-7 for 
the z-direction.

4 Click OK to visualize.

Due to the approximation with infinitely thin gold electrodes, the exact solution 
would have an infinite DEP force at the edges of the electrodes - the force is singular 
at the electrode edges. In the finite element simulation this is illustrated by the fact 
that the maximum value of the force at the edges grows without bound as the mesh 
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is refined. This is still a very useful simulation since at a small distance from the 
electrodes, the value of the DEP-force will be very accurate.

The only way to avoid a singular force field would be to model the electrodes with 
rounded corners and not sharp edges. This is technically possible but would require 
a finer mesh (to resolve the rounded corners) and be more memory consuming.

Impedance Computation

In order to demonstrate how to perform impedance (or admittance) computations 
(complex valued) we will assume, for simplicity, that we have a one-port structure 
where three of the electrodes are grounded and one is an input port. More 
information on lumped parameter computations for single and multiport structures 
can be found in the COMSOL Multiphysics 3.2 Electromagnetics Module User’s 
Guide pages 96-103, in the section called Lumped Parameters.

• From the Physics menu, select Boundary Settings.

• Set the Boundary condition of boundaries 3, 6, and 9 to Ground.

• Select boundary 8 and change the Boundary condition to Port. This enables the 
Port page.

• Click the Port page.

• Make sure the Port number is 1 and select the checkbox Use port as input.

• Change the Input property to Forced voltage.

• Click OK to close the dialog box.

• Click the Solve Problem (=) menu item or button to re-solve the problem.
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The visualization above shows the voltage distribution for the automatically 
computed load cases where the voltage of the input port is set to 1 V. If you have a 
multiport structure, a unit load will be applied in a cyclic manner as to create an 
impedance matrix Z or admittance matrix Y, depending on the type of load.

To see the value of the, in this case, complex valued admittance:

• From the Postprocessing menu, select Point evaluation.

• Click on an arbitrary point (the admittance variable(s) is(are) made available 
globally, say point 1.

• Change the Predefined quantities to Admittance matrix, element 11.

• Click Apply to evaluate the value of the variable Y11_emqvw.

A value of about 8.0e-6+6.2e-8i is printed at the bottom of the main GUI 
window, in the so called history log. This corresponds to Y=G+Bi, where G is the 
conductance and B is the susceptance. You get the impedance Z from the 
admittance as Z=1/Y=R+Xi, where R is the resistance and X the reactance. This 
model assumes that there is no inductive effect, only resistive and capacitive, so 
that X=-1/(2πfC), where f is the frequency and C is the capacitance. The following 
relationships will give us the capacitance C starting from the admittance:
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Y G Bi+=

Z 1
Y
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G2 B2+
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G2 B2+
-------------------i+ R Xi+= = = =

C 1
2πfX
------------– 1

2πf B–( )
G2 B2+
-------------------

----------------------------– G2 B2+
2πfB
-------------------= = =

With values inserted we get that the capacitance equals 
((8.0e-6)^2+(6.2e-8)^2)/(2*pi*fq*6.2e-8) and this can be calculated for 
instance by using the Constants dialog box as a pocket calculator.

The computed value of the capacitance is approximately 160 pF.

One can also define a scalar expression for the capacitance and then sweep over a 
range of frequencies to see the frequency dependent capacitance. We will use the 
real() and imag() operators to extract the value of G and B automatically from 
the computed lumped parameter variable Y11_emqvw:

• From the Options menu, select Expressions>Scalar Expressions.
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• Type in names and expressions according to the below picture:

We will sweep for the parameter fq, frequency. In this case the fact that we have 
already defined it as a constant is OK due to the fact that the parametric sweep 
variable will have precedence in the computation over any constant or expression. 
We renamed the capacitance C0 for not conflicting with the constant C calculated 
earlier.

• Click OK to close the dialog box.

• From the Physics menu, select Scalar Variables.

• Replace the value 1e6 for the frequency with the variable fq.

• Click OK to close the dialog box.

• From the Solve menu, select Solver Parameters.

• Set the Solver to Parametric linear.

• In the Parameter pane, type fq for the Name of parameter and 
linspace(1e6,5e6,10) for the List of parameter values. The linspace 
command creates 10 frequency cases linearly distributed between 1e6 and 5e6.

• Click OK to close the dialog box.

• Click the Solve Problem (=) menu item or button.

To plot the frequency dependent capacitance:

• From the Postprocessing menu, select Domain Plot Parameters.

• On the General page, make sure all parameters are highlighted (blue color).

• Click the Point tab.

• Highlight point number 1 (arbitrary).

• For the Expression, type C0.

• For the x-axis data, click the Expression button.
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• For the Expression type fq (for frequency).

• Click OK in the opened dialog boxes to get the following plot:

The capacitance decreases with increased frequency. This is typical for a capacitive 
device; it will have the characteristics of a high-pass filter.

Model Approximations

E L E C T R O D E  A P P R O X I M A T I O N

The perfect conductor approximation of the electrodes is justified by the fact that 
the real electrodes have a thickness of about 0.1µm and is made of gold and that no 
significant field dilatation will occur across the surfaces of the electrodes; all points 
at the gold surface will essentially have the same phase angle. In addition, the 
approximation with zero thickness means that edge effects from the vertical sides of 
the electrodes are neglected.

The perfect conductor approximation is also motivated by the contrast in 
conductivity between the buffer, 0.56 S/m, and the gold electrodes, 45.2·106 S/m 
that would be prohibitively large to resolve within the machine precision. For a finite 
element simulation 45.2·106 S/m is a virtually unlimited conductivity in 
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comparison with 0.56 S/m. Explicitly simulating such a large material property 
contrast might render an ill-conditioned finite element model and deteriorate 
accuracy since it would correspond to linear algebra system matrix entries with scale 
differences on the order of 108 (45.2·106/0.56).

T H E  E L E C T R I C  C U R R E N T S  A P P R O X I M A T I O N

The Electric Currents application mode is used to model devices with alternating 
currents (AC) where magnetic-inductive effects can be neglected and only 
resistive-conductive and electric-capacitive effects are accounted for. Generally 
speaking, this approximation gets better the lower the frequency and the smaller the 
device. When this approximation cannot be applied, you instead need to use the 
Electric and Induction Currents application mode.

S K I N  D E P T H

The characteristic length scale that determines the accuracy of the electric currents 
approximation is called the current skin depth δ:

δ 2
2πfσµ0µr
------------------------=

where f is the frequency (Hz), s is the electric conductivity, µ0 is the magnetic 
permeability of vacuum, and µr is the relative permeability. A higher frequency, 
conductivity, or permeability will give a smaller value of the skin depth.

At a high frequency, currents tend to flow close to the surface of a good conductor, 
the so called skin effect. This happens since induction currents are generated that 
flow in a direction opposite to any imposed currents and thereby eliminating the 
total (vector-sum) current inside the conductor. The skin depth is a characteristic 
penetration depth of the surface current sheet. If this measure is much larger than 
the device modeled, then magnetic, or inductive, effects can be neglected. In other 
words, the device is small enough that no skin effect can be seen.

R L C  C I R C U I T  E Q U I V A L E N T

Yet another way of viewing the electric current approximation is to say that there are 
resistance, R, and capacitance, C, contributions to the overall impedance but that 
the inductance, L, equals zero. Electric circuit theory then tells us that the device we 
model will act as a high-pass filter. A plot of the magnitude of the impedance vs. 
frequency will show the magnitude decreasing with higher frequency. 
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E L E C T R I C  P O T E N T I A L

If not for the electric current approximation, we would need to model the full 
electromagnetic field using the electric potential V and the magnetic vector potential 
A=(Ax,Ay,Az). This is available in the Quasi-Statics, Electric and Induction Currents 
application mode. However, the electric currents approximation makes use of the 
electric potential, V, alone. This greatly simplifies the modeling process since a 
smaller set of boundary conditions can be considered and the memory requirements 
tend to be low - we are solving for one unknown instead of four.

T H E  T I M E - H A R M O N I C  A N A L Y S I S  C A S E

This example uses the time-harmonic analysis type of the Electric Currents 
application mode. This means that the AC voltage and current is assumed to be 
sinusoidal in shape at one specific frequency. The so called j-omega method is used 
for this so that the voltage amplitude solved for, V(x,y,z), is a complex 
time-independent quantity that is related to the real-world voltage, Vhat, by the 
relationship:

V̂ x y z t, , ,( ) Real V x y z, ,( )ejωt{ } V̂ x y z, ,( ) ωt( )cos= =

The complex valued voltage V is also referred to as a phasor.

Having the voltage as a complex valued phasor has many advantages. One being that 
it is very easy to specify or measure phase differences. A phase shift phi at a boundary 
surface is modeled by multiplying the complex voltage amplitude by 
exp(j*w*phi). A real value of the voltage phasor means the phase phi equals zero. 
A zero voltage means ground which has no associated phase angle (undefined).

COMSOL Multiphysics lets you operate on any complex variable by the functions 
real(), imag(), abs(), and angle(), to retrieve the real part, imaginary part, 
absolute value (modulus), and phase angle, respectively. These functions are 
available for boundary, subdomain and material settings, as well as for 
postprocessing. All variables in COSMOL Multiphysics are allowed to be complex 
valued.

M A T E R I A L  P R O P E R T I E S

In the Electric Currents application mode, there are two material properties: the 
electric conductivity s and the relative electric permittivity εr. Often, these quantities 
are frequency dependent and you may use analytical expressions for them in the 
frequency variable with default name nu_emqvw. You can also use look-up table 
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functions, or user-defined functions from COMSOL Script. The parametric solver 
will then allow you to sweep for a range of frequencies.

In this example, the skin depth for the buffer at 1 MHz is:

δ 2
2πfσµ0µr
------------------------ 2

2π1060.56 1.3 10 6–⋅ ⋅ 1
---------------------------------------------------------= = 670m≈

This is significantly larger than the 30µm side of the modeled cube-shaped domain.

The skin depth for the gold electrodes is:

δ 2
2πfσµ0µr
------------------------ 2

2π10645.2 106 1.3 10 6–⋅ ⋅ ⋅ 1
----------------------------------------------------------------------= = 75µm≈

which is significantly larger than the electrode thickness 0.1 µm. At a higher 
frequency, the approximation of gold as a perfect conductor might not be valid and 
another method is needed such as an Electric Shielding boundary condition (surface 
impedance) or a full volume representation of the electrodes.

A D D I T I O N A L  I N F O R M A T I O N

You can read more on the Electric Currents application mode in the 
Electromagnetics User’s Guide.
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